$re = '/(?<=\d)DEC(?=[A-Z])/m';
$str = 'START1SEP2 1DECX JANEND';
$subst = " $0 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;