const regex = /(?<=\d)DEC(?=[A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d)DEC(?=[A-Z])', 'gm')
const str = `START1SEP2 1DECX JANEND`;
const subst = ` $0 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);