using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)DEC(?=[A-Z])";
string substitution = @" $0 ";
string input = @"START1SEP2 1DECX JANEND";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}