# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^<>\s](?![^<>]*>)/n/gm;t' <<< "sd<p><em>Hi [User</em></p>
<p><em>Tack för visat intresse.</em></p>
<p><em>Good luck!</em><em> </em></p>
<p><em>Sincerely</em></p>sd"