$re = '/[^<>\s](?![^<>]*>)/m';
$str = 'sd<p><em>Hi [User</em></p>
<p><em>Tack för visat intresse.</em></p>
<p><em>Good luck!</em><em> </em></p>
<p><em>Sincerely</em></p>sd';
$subst = "n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;