import re
regex = re.compile(r"[^<>\s](?![^<>]*>)", flags=re.MULTILINE)
test_str = ("sd<p><em>Hi [User</em></p>\n"
"<p><em>Tack för visat intresse.</em></p>\n"
"<p><em>Good luck!</em><em> </em></p>\n"
"<p><em>Sincerely</em></p>sd")
subst = "n"
result = regex.sub(subst, test_str)
if result:
print(result)