import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^<>\\s](?![^<>]*>)";
final String string = "sd<p><em>Hi [User</em></p>\n"
+ "<p><em>Tack för visat intresse.</em></p>\n"
+ "<p><em>Good luck!</em><em> </em></p>\n"
+ "<p><em>Sincerely</em></p>sd";
final String subst = "n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}