const regex = /[^<>\s](?![^<>]*>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^<>\\s](?![^<>]*>)', 'gm')
const str = `sd<p><em>Hi [User</em></p>
<p><em>Tack för visat intresse.</em></p>
<p><em>Good luck!</em><em> </em></p>
<p><em>Sincerely</em></p>sd`;
const subst = `n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);