# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\u(\w{4})/\\x{$1}/g;t' <<< "^(?:[A-Za-z0-9\u00C0-\u017F\u20AC\u2122\u2150\u00A9 \/.,\-_$!\'&*()=\"?#+%:;\<\[\]\r\r\n]|(?:\ud83c[\udf00-\udfff])|(?:\ud83d[\udc00-\ude4f\ude80-\udeff]))*$"