# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\\u(\w{4})"
test_str = "^(?:[A-Za-z0-9\\u00C0-\\u017F\\u20AC\\u2122\\u2150\\u00A9 \\/.,\\-_$!\\'&*()=\"?#+%:;\\<\\[\\]\\r\\r\\n]|(?:\\ud83c[\\udf00-\\udfff])|(?:\\ud83d[\\udc00-\\ude4f\\ude80-\\udeff]))*$"
subst = "\\\\x{$1}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.