import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\u(\\w{4})";
final String string = "^(?:[A-Za-z0-9\\u00C0-\\u017F\\u20AC\\u2122\\u2150\\u00A9 \\/.,\\-_$!\\'&*()=\"?#+%:;\\<\\[\\]\\r\\r\\n]|(?:\\ud83c[\\udf00-\\udfff])|(?:\\ud83d[\\udc00-\\ude4f\\ude80-\\udeff]))*$";
final String subst = "\\\\x{$1}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}