use strict;
my $str = '^(?:[A-Za-z0-9\\u00C0-\\u017F\\u20AC\\u2122\\u2150\\u00A9 \\/.,\\-_$!\\\'&*()="?#+%:;\\<\\[\\]\\r\\r\\n]|(?:\\ud83c[\\udf00-\\udfff])|(?:\\ud83d[\\udc00-\\ude4f\\ude80-\\udeff]))*$';
my $regex = qr/\\u(\w{4})/p;
my $subst = '\\\\x{$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";