$re = '/\\\\u(\w{4})/';
$str = '^(?:[A-Za-z0-9\\u00C0-\\u017F\\u20AC\\u2122\\u2150\\u00A9 \\/.,\\-_$!\\\'&*()="?#+%:;\\<\\[\\]\\r\\r\\n]|(?:\\ud83c[\\udf00-\\udfff])|(?:\\ud83d[\\udc00-\\ude4f\\ude80-\\udeff]))*$';
$subst = "\\x{$1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;