# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!_)_{1,2}(?=_[^_])|(?<=\.jav)a$//gm;t' <<< "remote_execute___jenkin%.java
remtoe__plat_jenk.java
remtoe_plat_jenk.java
remtoe___plat_jenk.testa
remote_execute____jenkin%.java"