#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!_)_{1,2}(?=_[^_])|(?<=\.jav)a$"
Local $sString = "remote_execute___jenkin%.java" & @CRLF & _
"remtoe__plat_jenk.java" & @CRLF & _
"remtoe_plat_jenk.java" & @CRLF & _
"remtoe___plat_jenk.testa" & @CRLF & _
"remote_execute____jenkin%.java"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)