use strict;
my $str = 'remote_execute___jenkin%.java
remtoe__plat_jenk.java
remtoe_plat_jenk.java
remtoe___plat_jenk.testa
remote_execute____jenkin%.java';
my $regex = qr/(?<!_)_{1,2}(?=_[^_])|(?<=\.jav)a$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";