import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!_)_{1,2}(?=_[^_])|(?<=\\.jav)a$";
final String string = "remote_execute___jenkin%.java\n"
+ "remtoe__plat_jenk.java\n"
+ "remtoe_plat_jenk.java\n"
+ "remtoe___plat_jenk.testa\n"
+ "remote_execute____jenkin%.java";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}