import re
regex = re.compile(r"(?<!_)_{1,2}(?=_[^_])|(?<=\.jav)a$", flags=re.MULTILINE)
test_str = ("remote_execute___jenkin%.java\n"
"remtoe__plat_jenk.java\n"
"remtoe_plat_jenk.java\n"
"remtoe___plat_jenk.testa\n"
"remote_execute____jenkin%.java")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)