# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([\da-zA-Z]{2})([\da-zA-Z]{2})(?=([\da-zA-Z]{6})).([\da-zA-Z].*)$/1st: \1\n2nd: \2\n3rd: \3\n4th: \4/gm;t' <<< "abcdefghijghij12345
"