const regex = new RegExp('^([\\da-zA-Z]{2})([\\da-zA-Z]{2})(?=([\\da-zA-Z]{6})).([\\da-zA-Z].*)$', 'gm')
const str = `abcdefghijghij12345
`;
const subst = `1st: \1\n2nd: \2\n3rd: \3\n4th: \4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);