use strict;
my $str = 'abcdefghijghij12345
';
my $regex = qr/^([\da-zA-Z]{2})([\da-zA-Z]{2})(?=([\da-zA-Z]{6})).([\da-zA-Z].*)$/mp;
my $subst = '1st: \\1\\n2nd: \\2\\n3rd: \\3\\n4th: \\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";