import re
regex = re.compile(r"^([\da-zA-Z]{2})([\da-zA-Z]{2})(?=([\da-zA-Z]{6})).([\da-zA-Z].*)$", flags=re.MULTILINE)
test_str = ("abcdefghijghij12345\n")
subst = "1st: \\1\\n2nd: \\2\\n3rd: \\3\\n4th: \\4"
result = regex.sub(subst, test_str)
if result:
print(result)