$re = '/^([\da-zA-Z]{2})([\da-zA-Z]{2})(?=([\da-zA-Z]{6})).([\da-zA-Z].*)$/m';
$str = 'abcdefghijghij12345
';
$subst = "1st: \1\n2nd: \2\n3rd: \3\n4th: \4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;