# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n(?!\d+,)/ /gm;t' <<< "id, text field1, text field2
1,some text,another text
2,some
1999-06-21 text,another text
3,some text,another text
1a,wewe
"