re = /\n(?!\d+,)/m
str = 'id, text field1, text field2
1,some text,another text
2,some
1999-06-21 text,another text
3,some text,another text
1a,wewe
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result