using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n(?!\d+,)";
string substitution = @" ";
string input = @"id, text field1, text field2
1,some text,another text
2,some
1999-06-21 text,another text
3,some text,another text
1a,wewe
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}