import Foundation
let pattern = #"\n(?!\d+,)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
id, text field1, text field2
1,some text,another text
2,some
1999-06-21 text,another text
3,some text,another text
1a,wewe
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)