# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n(?!\d+,)"
test_str = ("id, text field1, text field2\n"
"1,some text,another text\n"
"2,some \n"
"1999-06-21 text,another text\n"
"3,some text,another text\n"
"1a,wewe\n\n")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.