using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(or|and|(?:(?P<case1namE>)\() ?|) ?\w*(\.)?colz( like| ?\=) ?\?(?:(?P=case1namE) OR)?( and)?";
string input = @"technology=? AND tbl.colz = ?(notes.user_id like ? OR votes_count like ? OR notes.id like ?
OR notes.note like ? OR notes.link like ? OR notes.description like ?
OR technology like ? OR notes.code_link like ? OR notes.priority like ? OR notes.created_at like ?
OR notes.updated_at like ? OR notes.technology_id = ? OR notes.user_id like ?)
//replace colz with any column name(ex: technology_id) and it should work just as expected
//this expression is to capture and remove ""having"" columns from query without any error";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}