// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(or|and|(?:(?P<case1namE>)\() ?|) ?\w*(\.)?colz( like| ?\=) ?\?(?:(?P=case1namE) OR)?( and)?").unwrap();
let string = "technology=? AND tbl.colz = ?(notes.user_id like ? OR votes_count like ? OR notes.id like ?
OR notes.note like ? OR notes.link like ? OR notes.description like ?
OR technology like ? OR notes.code_link like ? OR notes.priority like ? OR notes.created_at like ?
OR notes.updated_at like ? OR notes.technology_id = ? OR notes.user_id like ?)
//replace colz with any column name(ex: technology_id) and it should work just as expected
//this expression is to capture and remove \"having\" columns from query without any error";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}