import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(or|and|(?:(?P<case1namE>)\\() ?|) ?\\w*(\\.)?colz( like| ?\\=) ?\\?(?:(?P=case1namE) OR)?( and)?";
final String string = "technology=? AND tbl.colz = ?(notes.user_id like ? OR votes_count like ? OR notes.id like ?\n"
+ "OR notes.note like ? OR notes.link like ? OR notes.description like ? \n"
+ "OR technology like ? OR notes.code_link like ? OR notes.priority like ? OR notes.created_at like ?\n"
+ "OR notes.updated_at like ? OR notes.technology_id = ? OR notes.user_id like ?)\n\n\n"
+ "//replace colz with any column name(ex: technology_id) and it should work just as expected\n\n"
+ "//this expression is to capture and remove \"having\" columns from query without any error";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}