import re
regex = re.compile(r"(or|and|(?:(?P<case1namE>)\() ?|) ?\w*(\.)?colz( like| ?\=) ?\?(?:(?P=case1namE) OR)?( and)?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("technology=? AND tbl.colz = ?(notes.user_id like ? OR votes_count like ? OR notes.id like ?\n"
"OR notes.note like ? OR notes.link like ? OR notes.description like ? \n"
"OR technology like ? OR notes.code_link like ? OR notes.priority like ? OR notes.created_at like ?\n"
"OR notes.updated_at like ? OR notes.technology_id = ? OR notes.user_id like ?)\n\n\n"
"//replace colz with any column name(ex: technology_id) and it should work just as expected\n\n"
"//this expression is to capture and remove \"having\" columns from query without any error")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")