package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(or|and|(?:(?P<case1namE>)\() ?|) ?\w*(\.)?colz( like| ?\=) ?\?(?:(?P=case1namE) OR)?( and)?`)
var str = `technology=? AND tbl.colz = ?(notes.user_id like ? OR votes_count like ? OR notes.id like ?
OR notes.note like ? OR notes.link like ? OR notes.description like ?
OR technology like ? OR notes.code_link like ? OR notes.priority like ? OR notes.created_at like ?
OR notes.updated_at like ? OR notes.technology_id = ? OR notes.user_id like ?)
//replace colz with any column name(ex: technology_id) and it should work just as expected
//this expression is to capture and remove "having" columns from query without any error`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}