use strict;
my $str = 'technology=? AND tbl.colz = ?(notes.user_id like ? OR votes_count like ? OR notes.id like ?
OR notes.note like ? OR notes.link like ? OR notes.description like ?
OR technology like ? OR notes.code_link like ? OR notes.priority like ? OR notes.created_at like ?
OR notes.updated_at like ? OR notes.technology_id = ? OR notes.user_id like ?)
//replace colz with any column name(ex: technology_id) and it should work just as expected
//this expression is to capture and remove "having" columns from query without any error';
my $regex = qr/(or|and|(?:(?P<case1namE>)\() ?|) ?\w*(\.)?colz( like| ?\=) ?\?(?:(?P=case1namE) OR)?( and)?/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}