using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ExceptionName:\s+(?<message>[^\.\<]+)";
string input = @"stack_trace : com.abc.xyz.package.ExceptionName: Missing A.
stack_trace : com.abc.xyz.package.ExceptionName: Missing B <abcd> com.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}