$re = '/ExceptionName:\s+(?<message>[^\.\<]+)/m';
$str = 'stack_trace : com.abc.xyz.package.ExceptionName: Missing A.
stack_trace : com.abc.xyz.package.ExceptionName: Missing B <abcd> com.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);