package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ExceptionName:\s+(?<message>[^\.\<]+)`)
var str = `stack_trace : com.abc.xyz.package.ExceptionName: Missing A.
stack_trace : com.abc.xyz.package.ExceptionName: Missing B <abcd> com.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}