const regex = /ExceptionName:\s+(?<message>[^\.\<]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ExceptionName:\\s+(?<message>[^\\.\\<]+)', 'gm')
const str = `stack_trace : com.abc.xyz.package.ExceptionName: Missing A.
stack_trace : com.abc.xyz.package.ExceptionName: Missing B <abcd> com.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}