import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ExceptionName:\\s+(?<message>[^\\.\\<]+)";
final String string = "stack_trace : com.abc.xyz.package.ExceptionName: Missing A.\n"
+ "stack_trace : com.abc.xyz.package.ExceptionName: Missing B <abcd> com.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}