package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]+(?:_[a-z]+)*$`)
var str = `welcome_to_snake_case
PASS :
snake_case
cellule
sous_cellule
a
a_a
all_good
FAIL :
/^[a-z]+(\_[a-z]+)*$/gm
camelCase
PascalCase
kebab-case
UPPERCASE
big_sNAKe_case
snake_digita1ised_case
one_is_there^
_
___
no_trailing_dash_
_actually_neither_way
_norboth_
no_space
no_other_special-char
all_good?yes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}