import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z]+(?:_[a-z]+)*$";
final String string = "welcome_to_snake_case\n\n"
+ "PASS :\n"
+ "snake_case\n"
+ "cellule\n"
+ "sous_cellule\n"
+ "a\n"
+ "a_a\n"
+ "all_good\n\n"
+ "FAIL :\n"
+ "/^[a-z]+(\\_[a-z]+)*$/gm\n"
+ "camelCase\n"
+ "PascalCase\n"
+ "kebab-case\n"
+ "UPPERCASE\n"
+ "big_sNAKe_case\n"
+ "snake_digita1ised_case\n"
+ "one_is_there^\n"
+ "_\n"
+ "___\n"
+ "no_trailing_dash_\n"
+ "_actually_neither_way\n"
+ "_norboth_\n"
+ "no_space \n"
+ "no_other_special-char\n"
+ "all_good?yes";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}