const regex = /^[a-z]+(?:_[a-z]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]+(?:_[a-z]+)*$', 'gm')
const str = `welcome_to_snake_case
PASS :
snake_case
cellule
sous_cellule
a
a_a
all_good
FAIL :
/^[a-z]+(\\_[a-z]+)*\$/gm
camelCase
PascalCase
kebab-case
UPPERCASE
big_sNAKe_case
snake_digita1ised_case
one_is_there^
_
___
no_trailing_dash_
_actually_neither_way
_norboth_
no_space
no_other_special-char
all_good?yes`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}