# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-z]+(?:_[a-z]+)*$"
test_str = ("welcome_to_snake_case\n\n"
"PASS :\n"
"snake_case\n"
"cellule\n"
"sous_cellule\n"
"a\n"
"a_a\n"
"all_good\n\n"
"FAIL :\n"
"/^[a-z]+(\\_[a-z]+)*$/gm\n"
"camelCase\n"
"PascalCase\n"
"kebab-case\n"
"UPPERCASE\n"
"big_sNAKe_case\n"
"snake_digita1ised_case\n"
"one_is_there^\n"
"_\n"
"___\n"
"no_trailing_dash_\n"
"_actually_neither_way\n"
"_norboth_\n"
"no_space \n"
"no_other_special-char\n"
"all_good?yes")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.