use strict;
my $str = 'welcome_to_snake_case
PASS :
snake_case
cellule
sous_cellule
a
a_a
all_good
FAIL :
/^[a-z]+(\\_[a-z]+)*$/gm
camelCase
PascalCase
kebab-case
UPPERCASE
big_sNAKe_case
snake_digita1ised_case
one_is_there^
_
___
no_trailing_dash_
_actually_neither_way
_norboth_
no_space
no_other_special-char
all_good?yes';
my $regex = qr/^[a-z]+(?:_[a-z]+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}