using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]\S*(?:\s+[a-z]\S*)?)\s+((?:[A-Z]\S*\s*)?(?:\b[^A-Z\s]\S*\s*)*)(?:\s+|$)";
string substitution = @"$1: $2\n";
string input = @"Machine washable Yes Color Clear Series Share Capacity 123 cl Category Vase Brand RandomBrand Item.nr 43140";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}