use strict;
my $str = 'Machine washable Yes Color Clear Series Share Capacity 123 cl Category Vase Brand RandomBrand Item.nr 43140';
my $regex = qr/([A-Z]\S*(?:\s+[a-z]\S*)?)\s+((?:[A-Z]\S*\s*)?(?:\b[^A-Z\s]\S*\s*)*)(?:\s+|$)/p;
my $subst = '$1: $2\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";