const regex = /([A-Z]\S*(?:\s+[a-z]\S*)?)\s+((?:[A-Z]\S*\s*)?(?:\b[^A-Z\s]\S*\s*)*)(?:\s+|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z]\\S*(?:\\s+[a-z]\\S*)?)\\s+((?:[A-Z]\\S*\\s*)?(?:\\b[^A-Z\\s]\\S*\\s*)*)(?:\\s+|$)', 'g')
const str = `Machine washable Yes Color Clear Series Share Capacity 123 cl Category Vase Brand RandomBrand Item.nr 43140`;
const subst = `$1: $2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);