$re = '/([A-Z]\S*(?:\s+[a-z]\S*)?)\s+((?:[A-Z]\S*\s*)?(?:\b[^A-Z\s]\S*\s*)*)(?:\s+|$)/';
$str = 'Machine washable Yes Color Clear Series Share Capacity 123 cl Category Vase Brand RandomBrand Item.nr 43140';
$subst = "$1: $2\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;