package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(?:^(?:<[^>]*>)?|\s)(he|lead[a-z]*)\b`)
var str = `Leading a team of 5.
You will be leading a team of 5
<span style="color:#f0f;">Leading a team of 5</span>
The code is ok
He is a good coder
test the leading test !@#$leading
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}