const regex = /(?:^(?:<[^>]*>)?|\s)(he|lead[a-z]*)\b/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^(?:<[^>]*>)?|\\s)(he|lead[a-z]*)\\b', 'gim')
const str = `Leading a team of 5.
You will be leading a team of 5
<span style="color:#f0f;">Leading a team of 5</span>
The code is ok
He is a good coder
test the leading test !@#\$leading
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}